BTweeps - Unresponsive Servers – Incident details

Experiencing partial outage

Unresponsive Servers

Resolved
Operational
Started over 4 years agoLasted about 1 hour

Affected

Website

Operational from 5:16 PM to 6:17 PM

App

Operational from 5:16 PM to 6:17 PM

Servers

Operational from 5:16 PM to 6:17 PM

Updates
  • Resolved
    Resolved

    We just resolved the issue! :) Thank you for your patience.

  • Investigating
    Investigating

    We are currently investigating this incident🚨

    Feel free to tweet your queries @BTweeps_ or Reach out to Support at btweeps@bizboost.me